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1: Background and Dataset Summary 
 

1.1: Background  
 
Over the past few decades, there has been a significant rise in physical inactivity-related health conditions (e.g., 
diabetes, cardiovascular disease) among Canadians [1-5]. This trend has prompted interest in promoting built 
environments that facilitate physical activity during activities of daily life (e.g., walking for transportation) as a 
population-level health intervention [6-9]. This dataset provides public health researchers with a Canada-wide 
set of Geographic Information Systems (GIS) measures that indicate the active living friendliness, sometimes 
referred to as the “walkability”, of neighbourhoods.  
 

This document is intended for researchers who have a basic understanding of GIS and those with a research 
interest in active living environments (ALEs) across Canada. Communities with favourable ALEs are those 
whose built environments are conducive to physical activity resulting from walking, cycling, and the use of public 
transportation. These built environments tend to be densely populated, have very connected street patterns and 
have a variety of walking destinations.  

 

1.2: About Can-ALE  
 
The Canadian Active Living Environments (Can-ALE) database is a geographic-based set of measures that 
represents the active living friendliness of Canadian communities. The primary envisioned use for Can-ALE is 
research and analysis of the relationship between the way communities are built and the physical activity levels 
of Canadians. By using geography conversion tools such as the Postal Code Conversion File (PCCF+) [10] (see 
Table A3, page 19 for URL), it is possible to link Can-ALE measures to individual-level health data from national-
level survey platforms (e.g., National Population Health Survey, Canadian Community Health Survey) or to local-
level data, such as travel surveys (e.g., Transportation Tomorrow Survey, Montreal Origin-Destination Survey). 
 
Each of the measures was selected from fourteen potential measures identified by a literature review. Several 
considerations were weighed in deriving the Canada-wide set of measures, including: (1) the suitability of each 
measure across different Canadian regions and built areas (e.g., urban, suburban, rural areas); (2) the 
incorporation of high-quality, open and free-to-use data sources; and (3) the strength of the association between 
the derived measures with walking rates and active transportation (i.e., walking, cycling, and public transit use). 
Public transit use is included in our definition of active transportation, as public transit is shown to generate 
physical activity via walking to and from transit stops [11-13]. 

1.2.1: Reference years 

There are two Can-ALE datasets: the 2006 Can-ALE Dataset includes two measures derived from 2006 data for 

geographic units corresponding to 2006 geographies, whereas the 2016 Can-ALE dataset includes four 

measures derived from 2016 or 2017 data for geographic units corresponding to 2016 geographies. Census 

years were selected for the dataset to facilitate the use of census data by users. Users are discouraged from 

performing longitudinal analyses using data from both the 2006 and 2016 datasets, as the derivation 

methodologies and census geographies changed between the reference years. 
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1.2.2: Geographic unit of analysis 

Can-ALE measures are based on one-kilometre, circular (Euclidean) buffers drawn from the centre points 
(centroids) of Dissemination Areas (DAs). DAs are small geographic units defined by Statistics Canada, with a 
population of between 400 to 700 persons. All of Canada is divided into DAs. This is the smallest geographic 
unit for which complete census data is released across all of Canada [14]. DA boundaries are created by and 
can be downloaded online from Statistics Canada [15, 16] (see Table A3, page 19 for URL).  
 

1.2.3: File format and naming convention 

Both Can-ALE datasets are provided in the Comma Separated Values (.csv) format. This file format may be 

opened easily in spreadsheet programs (e.g., Microsoft Excel, Google Sheets) and statistical software (e.g., 

STATA, SPSS, R). 

The datasets are named using the following naming convention: six-character file name (i.e., “CanALE”), 

underscore (“_”), reference year for the geographic units (e.g., “2016”). The two files, therefore, are: 

  

Dataset 2006 Can-ALE Dataset 2016 Can-ALE Dataset 

File Name CanALE_2006.csv CanALE_2016.csv 

 

 

1.2.4: Dataset completeness 

For the 2006 dataset, two measures were produced for all dissemination areas (DAs) in Canada (intersection 
density and dwelling density). For the 2016 dataset, three measures were produced for all DAs in Canada 
(intersection density, dwelling density, and points of interest), and one measure was produced for all DAs within 
Census Metropolitan Areas (CMAs) in Canada (transit stops).  
 
Intersection density was derived successfully for all DAs for both 2006 and 2016, and points of interest was 

derived successfully for all DAs for 2016.  

Dwelling density values are not present for 410 DAs in 2006 and 500 DAs in 2016 (see Table A2, pages 17-18). 

All DAs with no values (null) are assigned a period (“.”). In all instances of null dissemination area values, the 

DA buffer was located entirely within a DA where Statistics Canada does not disseminate data on dwelling counts 

(e.g., First Nations reserves). 

The transit measure (unique to the 2016 dataset) covers DAs in Canada’s largest cities, known as Census 

Metropolitan Areas (CMAs). The transit measure was derived for 35,338 DAs (97.1% of the DAs within CMAs). 

Spatial data on transit stop locations was unavailable for a few smaller CMAs: Belleville, ON; Peterborough, 

ON; Saguenay, QC; and Trois-Rivières, QC. 
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1.3: Field Directories and Measure Definitions 
 
The active living environment measures included in Can-ALE are calculated from circular buffers based on 
centroids of dissemination areas (DAs), rather than the boundaries themselves (see Section 1.2.2, page 5). For 
instance, if the number of points of interest is indicated as “60”, there are 60 points of interest within one kilometre 
of the centre point of that dissemination area. 
 
For the 2006 dataset, intersection density and dwelling density measures were derived across Canada. No open-
use historical datasets were available to derive the points of interest or transit measures in 2006. 
 
For the 2016 dataset, three ALE measures are included for all of Canada (intersection density, dwelling density, 
and points of interest) and one measure is provided for DAs within CMAs (transit stops). A detailed protocol of 
how each measure was derived is provided in Section 2 (page 9). There are a few null values for the dwelling 
density and transits stop measures (see Section 1.2.4, page 5).  
 
Summary statistics for each of the ALE measures is provided in the appendix (Table A1, page 16). Each of the 
datasets also includes z-scores for each measure, a summarized index measure (ALE Index), and a categorical 
measure of the favourability of the active living environment (see Sections 1.5 and 1.6, page 8).  
 

Table 1: Field Directory for 2006 Can-ALE Dataset (54,624 Dissemination Areas) 

 

 

  

Field name Full name Definition 
Derivation 
sources 

DAUID 
Dissemination area 
– unique ID 

Unique identifier of the dissemination area (eight 
digits) 

Statistics Canada 
(Boundary Files, 
2006) 

INT_D Intersection density 
The number of ≥3-way intersections per square 
kilometre in the buffer around a dissemination area 
centroid 

Statistics Canada 
(Road Network File, 
2006) 

DWL_D Dwelling density 
The number of dwellings per square kilometre in the 
buffer around a dissemination area centroid 

Statistics Canada 
(Census 2006) 

Z_INT_D 
Intersection density 
(z-score) 

Z-score of the intersection density measure 
Statistics Canada 
(Road Network File, 
2006) 

Z_DWL_D 
Dwelling density 
(z-score) 

Z-score of the dwelling density measure 
Statistics Canada 
(Census 2006) 

ALE_INDEX 
Active Living 
Environment Index 

Sum of the z-score of the intersection density, 
dwelling density, and points of interest measures 

- 

ALE_CLASS 
Active Living 
Environment class 

Categorical value characterizing the favourability of 
the ALE on a scale from 1 (very low) to 5 (very high) 

- 
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Table 2: Field Directory for 2016 Dataset (56,589 Dissemination Areas) 

  

Field name Full name Definition 
Derivation 
sources 

DAUID 
Dissemination area 
– unique ID 

Unique identifier of the dissemination area (eight 
digits) 

Statistics Canada 
(Boundary Files, 
2016) 

INT_D Intersection density 
The number of ≥3-way intersections per square 
kilometre in the buffer around a dissemination area 
centroid 

OpenStreetMap road 
and footpath features 
(downloaded 2017) 

DWL_D Dwelling density 
The number of dwellings per square kilometre in 
the buffer around a dissemination area centroid 

Statistics Canada 
(Census 2016) 

POI Points of interest 
The number of points of interest in the buffer 
around a dissemination area centroid 

OpenStreetMap 
amenity features 
(downloaded 2017) 

Z_INT_D 
Intersection density 
(z-score) 

Z-score of the intersection density measure 
OpenStreetMap road 
and footpath features 
(downloaded 2017) 

Z_DWL_D 
Dwelling density 
(z-score) 

Z-score of the dwelling density measure 
Statistics Canada 
(Census 2016) 

Z_POI 
Points of interest 
(z-score) 

Z-score of the points of interest measure 
OpenStreetMap 
amenity features 
(downloaded 2017) 

ALE_INDEX 
Active Living 
Environment Index 

Sum of the z-score of the intersection density, 
dwelling density, and points of interest measure 

- 

ALE_CLASS 
Active Living 
Environment class 

Categorical value characterizing the favourability of 
the ALE on a scale from 1 (very low) to 5 (very 
high) 

- 

TRANSIT Transit stops 
The number of public transit stops or stations in 
the buffer around a dissemination area centroid 

Canadian 
municipalities and 
transit agencies 

Z_TRANSIT 
Transit stops (z-
score) 

Z-score of the transit measure 
Canadian 
municipalities and 
transit agencies 

ALE_TRANSIT 
Transit stops (z-
score) 

Sum of the z-score of the intersection density, 
dwelling density, points of interest, and transit 
measures 

- 

ALE_TRANSIT 
_CLASS 

Active Living 
Environment + 
Transit class 

Categorical value characterizing the favourability of 
the ALE in CMAs on a scale from 1 (very low) to 5 
(very high) 

- 
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1.4: Guidelines for Use 

1.4.1: Caution for Analysis of Certain DAs in Rural Areas 

Although Can-ALE measures are valid for most rural areas, there are certain DAs with uncommon built or 

economic environments that may affect statistical analysis (e.g., isolated resort areas, remote communities not 

connected by road, fishing or hunting camps). 

1.4.2: Caution Against Comparing 2006 and 2016 Datasets 

The field names in both the 2006 and 2016 datasets are similar, but the ALE measures are not directly 
comparable between years. First, there were some boundary changes in the dissemination areas (DAs) between 
2006 and 2016. Second, due to limited historical data availability, intersection density was derived using different 
road files between years: the Statistics Canada Road Network File was used for the 2006 dataset and 
OpenStreetMap road and footpath features were used for the 2016 dataset. Accordingly, the 2006 and 2016 
datasets are best suited to cross-sectional analyses. Only the dwelling density measures from 2006 and 2016 
can be compared directly, and only for DAs where boundaries did not change between the two census years.  

 

1.5: Explanation of the ALE Index & the ALE/Transit Index 
 
A summarized, single measure of active living environments (ALE Index) is provided for both the 2006 and 2016 
datasets. The ALE Index is the sum of the z-scores for each ALE measure available throughout Canada for that 
census year (i.e., intersection density and dwelling density for 2006 and intersection density, dwelling density, 
and points of interest for 2016). The summed z-scores, or ALE Index, therefore, indicate the distribution of the 
ALE measure values for each DA relative to all DAs in Canada: negative ALE index scores indicate below 
average ALE measures and positive ALE index scores indicate above average ALE measures. A z-score near 
zero indicates that the DA is near the Canadian average for the quality of the active living environment. The ALE 
Index was not calculated for DAs with missing data (see Section 1.2.4, page 5).  
 
The ALE/Transit Index is an additional index provided for the 2016 dataset and includes the z-score of the transit 
measure as a fourth, summed indicator. The ALE/Transit Index, therefore, indicates the distribution of the DA 
relative to DAs within included Canadian CMAs: values near zero indicate an ALE near the average for the 
included CMAs. 
 

1.6: Explanation of the ALE Class Variable 
 
The ALE Class variable is a categorical measure of the active living environment. Each DA is assigned a value 
from 1 (very low) to 5 (very high) which characterizes the favourability of the active living environment. A cluster 
analysis (k-medians approach) was performed to assign each DA to one of the five groups. In 2006, the k-
medians cluster was based on two measures at the DA: intersection density and dwelling density. In 2016, the 
k-medians cluster was based on three measures at the DA: intersection density, dwelling density, and points of 
interest. 
 
A similar measure, ALE/Transit Class, is provided for DAs in CMAs). Similar to the ALE class measure, the 
ALE/Transit Class measure categorizes CMA DAs into five categories according to their active living friendliness 
based on four measures at the DA: intersection density, dwelling density, points of interest, and transit stops. 
The mean value of each of the ALE measures for each cluster group is reported in the Appendix (Table A4, page 
20), as well as reference maps that visualize the distribution of the cluster groups in four Canadian urban areas 
(Figure A1, page 22).  
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2: Protocol for Deriving the ALE Measures 
 

2.1: Data Preparation 

2.1.1: Software 

Three Geographic Information System (GIS) software packages were used to derive the Active Living 
Environment (ALE) measures: ArcMap v10.5.1, QGIS v2.18.13, and PostGIS v2.3.3. ArcMap and QGIS were 
used for most data preparation, while all final measures were derived using PostGIS. PostGIS is a GIS extension 
for the PostgreSQL object-relational database management system. While ArcMap is proprietary software, the 
other two programs are free and open source, and can be downloaded and installed easily. This protocol 
describes deriving the ALE measures in QGIS and PostGIS. Links for all necessary software are provided in the 
appendix (Table A3, page 19). 

2.1.2: Acquiring Data 

Data is taken entirely from free, open-use sources. Statistics Canada data was obtained to derive dissemination 
areas buffers and dwelling densities for both datasets, and intersection density for the 2006 dataset. Road and 
footpath features from OpenStreetMap were used for 2016 intersection density, as the added detail of off-road 
footpaths was found to strengthen the intersection density measure’s association with walking rates. The data 
sources are summarized and download URLs are provided in the appendix (Table A3, page 19). 
 
Data from online portals of municipal governments and transit authorities that operate in Census Metropolitan 
Areas (CMAs) was used to calculate the transit stop measure. This data was located using TransitFeeds, an 
online portal which provides links to datasets from various authoritative sources which use the Google Transit 
Feed Specification (GTFS) data standard. If data was not found via TransitFeeds, searches of municipal and 
transit agency websites for each CMA were conducted. Although spatial data was found for most transit agencies 
within CMAs, no spatial transit data was found for four smaller CMAs (see Section 1.2.4, page 5). 
 

2.1.3: Spatial Reference 

All geometric and spatial analysis functions were performed in PostGIS, in order to balance the need to derive 
measures using a Canada-wide projection with the need for spatial and statistical accuracy. The North American 
Datum 1983 (a.k.a., NAD 83, SRID: 4269) projection was used to calculate areas and distances and the spatial 
information was stored in the “geometry” column. The World Geodetic System 1984 (a.k.a., WGS 84, SRID: 
4326) projection was stored in the “geography” column and was used for topological functions, such as polygon 
intersection.  
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2.2: Intersection Density Measure  
 

The intersection density measure captures the directness and connectedness of streets and/or paths through a 
community. This is done by counting the number of three or more way intersections within a one kilometre buffer 
of the dissemination area (DA) centroid. Intersection density is derived using the Statistics Canada Road Network 
File for the 2006 dataset and OpenStreetMap road and footpath features in the 2016 dataset. In the both 
datasets, limited-access highways (e.g., freeways, 400-Series Ontario Highways, Quebec Autoroutes) and 
highway entrances and exits are removed from the files before calculating intersection density, as these roads 
typically restrict active transport. The classification of highways varies slightly, however, between the data 
sources, so both procedures for removing highway features are described below. For the 2016 measure, off-
road footpaths and recreational trails were added to the files. While the process of creating the two measures is 
similar, there are important methodological and dataset differences, thus the measures are not directly 
comparable. The differences in methodology are noted in the steps below. 
 

Step 1: Acquiring and preparing the data 
 1.1: Construct the Dissemination Area buffers.  
 

Download the Dissemination Areas (DAs) from Statistics Canada, choosing the cartographic 
boundaries and shapefile extension options. Ensure that the DA boundary file year corresponds 
to the data and/or dataset you wish to use. Open in QGIS. 

 

Use Vector > Geometry Tools > Polygon Centroids to produce polygon centroids for each DA. 
This may take a few minutes. Save centroid file.  

 

Use Vector > Geoprocessing tools > Fixed Distance Buffers to produce one kilometre buffers of 
the DA centroids. This also may take a few minutes. Save the buffer file(s).  

 

1.2: Prepare road network file 
 

Download the OpenStreetMap road features or Statistics Canada Road Network File. 
 
If using OpenStreetMap, download OSM “extracts” for each province and territory. Open each 
zipped folder in QGIS. Save zipped folders. 

 

Open the gis.osm_roads_free_1.shp file from each zipped province folder. Merge all the roads 
into one file using Vector > Data Management Tools > Merge Vector Layers. Save merged file. 

 

 

 

Step 2: Clean Road Features 
2.1a Remove non-pedestrian road features: (Follow if using OpenStreetMap data, consistent with 
2016 methodology)  

 

Filter the merged roads using the filter menu that appears when right clicking on the layer in the 
layers panel. 
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The following Query will select the desired road segments. This query retains footpaths and 
excludes limited-access highways and their entrances and exits. Save filtered layer as new 
shapefile.  

 

"fclass" = 'trunk' OR "fclass" = 'primary' OR "fclass" = 'primary' OR "fclass" = 'secondary' OR 
"fclass" = 'tertiary' OR "fclass" = 'unclassified' OR "fclass" = 'residential' OR "fclass" = 'pedestrian' 
OR "fclass" = 'living_street' OR "fclass" = 'footway' OR "fclass" = 'steps' OR "fclass" = 'path' 

 

2.1b: Remove non-pedestrian road features: (Follow using Statistics Canada data, consistent with 
2006 methodology) 
 
 Due to inconsistent road classifications in the 2006 Statistics Canada Road Network File, we used 
 a buffer around OSM ‘motorway’ classified roads to identify limited-access highways.  

 

Obtain the OSM road and footpath using the methodology from the previous step. Filter the OSM 
street file to select limited-access highway features, using the query: “fclass”=’motorway’. Save 
selected features as a separate layer. Create a 10 metre buffer around the motorway features. 
Save. Open the Statistics Canada Road Network File. Use the erase tool to remove features 
overlapping with the buffer file from the Road Network File. Save output. The output now contains 
all of the road features in Canada, with limited-access highways removed.  

 

Step 3: PostGIS Processing 
 3.1: Import Layers into PostGIS  
 

  Open PgAdmin4 (automatically installs when PostgreSQL and the PostGIS extension are  
   downloaded). 
  

Import DA Buffers and streets file(s) (cleaned in step 2) into PostGIS using the Database > 
Database Manager > PostGIS import tool. Select the “Create spatial index” and the “Convert field 
names to lowercase” options. Specify the target geometry field SRID as ‘4269’ (NAD 83). 

 

 3.2: Preparing PostGIS Data  
 

Create geography column for streets and buffers tables using the ST_Transform function. Specify 
the geography field SRID as ‘4326’ (WGS 84). 

 
 3.3: Intersection counting function.  
 

  Create ≥3-way intersections table using the streets table and ST_Intersection function.   
 

Count intersections in buffers using the ST_Intersects function and create a new table 
 

Save the output using COPY. This is your raw intersection measure. Calculate z-scores for each 
observation for final measure. 
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2.3: Dwelling Density Measure  
 

This measure captures the average dwelling density of the DAs in the buffer area. This is a common measure 
of active living environments and strongly correlates with active transportation rates. Note that DAs with null 
values are removed before running the script to avoid calculation errors. 

 

Step 1: Acquire and prepare data 
 1.1: Join Dwelling Counts to DAs 
 

  Download dwelling counts for DAs from CHASS (see Table 4 for link).  
 

Open dwelling counts in QGIS as table with no geometry. Open DA boundaries (not buffers) from 
previous measure. 

 

Join dwelling count to DA Boundaries by right clicking on DA boundaries layer, selecting 
properties and then joins. Join based on DA and DAUID. Save new joined layer as separate file. 
Next remove all DAs that have null values (not zero values!) for dwelling density from the shapefile 
by using the filter tool to select non-null values. Save the output. This will be the file imported into 
PostGIS. 

 

1.2: Create DA Buffers  
 

Use DA buffers that have already been created for Intersection Density Measure and are in 
PostGIS environment already. If you have not done this measure yet, see Section 2.2, Step 1. 

 

Step 2: PostGIS Processing 
 2.1: Import Layers into PostGIS  
 

  Open PgAdmin4 that has been installed with PostGIS extension.  
 

Import DA Buffers (if this has not already been done) and DA boundaries with Dwelling Counts 
and No Null value DAs into PostGIS using Database > Database Manager > PostGIS. Check the 
create spatial index box and the convert field names to lowercase box. Make sure to specify the 
Geom SRID as 4269. 

 

 2.2: Prepare PostGIS Data  
 

Create geography column for DA boundries using the ST_Transform function. Specify the 
geography field SRID as ‘4326’ (WGS 84). 

 

` 2.3: PostGIS Processing  
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Calculate average dwelling density using ST_Intersection, ST_Intersects, and ST_Area.  
 

Save the output using COPY. This is your raw dwelling density measure. Calculate z-scores for 
each observation for final measure. 

 

2.4: Points of Interest Measure  
 

This measure captures the number of points of interest (POIs) in a one kilometre buffer around the DA centroids. 
These points include a wide range of potential walking destinations (e.g., parks, schools, shops, places of 
business, landmarks, etc.). Almost all OSM POIs (a.k.a., “amenities”) are included in our measure; the POIs 
excluded are alpine huts, caravan sites, wayside crosses and a few other features that likely have no relationship 
with walking.  This specific subset of OSM POIs was chosen after a number of POI subsets were tested. The 
presence of points of interest is strongly associated with active transportation rates. 

 

Step 1: Acquire and prepare the data 

 1.1: Acquire POIs from OpenStreetMap 
Inside the zipped Canadian Provincial Extracts folders there are two POI shapefiles: “POI” and 
“POI_a”. POI has POIs stored as points. POI a has POIs stored as polygons. Open these files in 
QGIS.  

 

Merge all the POI points into one file using Vector > Data Management Tools > Merge Vector 
 Layers. Save merged file.  

 
Merge all the POI_a polygons into one file using Vector > Data Management Tools > Merge 

 Vector Layers. Save merged file. 
 
 
To make the geometry of these files comparable the polygons must be converted to points. Use 

 the Vector > Geometry Tools > Polygon Centroids to produce polygon centroids for each 
 “POI_a” polygon from the merged file. Save centroid file.  

 
Now merge the two Canada wide POIs as points files to form a single file. Save.  

 

 1.2: Remove undesired POIs  
 
  To remove POIs that are not relevant to active living environments (e.g., utility lines), select  
  features from the merged Canada wide POI layer. Open the filter window by right clicking on the 
  layer. Use the query below. Note the code corresponds to the standard OSM classification.  
 

  “code” NOT IN (2423, 2725, 2424, 2951, 2961, 2734, 2422) 
 

 1.3: Create DA Buffers  
 

Use DA buffers that have already been created for Intersection Density Measure and are in 
PostGIS environment already. If you have not done this measure yet, see Section 2.2, Step 1. 
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Step 2: PostGIS Processing 
 2.1: Load the data into PostGIS 
 
  Open PgAdmin4 that has been installed with PostGIS extension.  
 
  Import DA Buffers (if this has not already been done) and POIs into PostGIS using Database  
  > Database Manager > PostGIS. Check the create spatial index box and the convert field  
  names to lowercase box. Make sure to specify the Geom SRID as 4269. 
  
 2.2: Prepare PostGIS Data  
 

Create geography column for tables using the ST_Transform function. Specify the geography 
field SRID as ‘4326’ (WGS 84). 

 
   

2.3: Count the POIs in the buffers 
 
 Count POIs and place output in table. Use ST_Intersects.  

 

 Save the output using COPY. This is your POI count.  

 

2.5: Transit Measure 
 

The transit measure is meant to capture the presence of public transit stops in the community. The process 
involved in creating it is almost identical to the creation of the POI measure. Note that this measure only covers 
DAs within Census Metropolitan Areas (CMAs). The websites of transit agencies and/or municipalities from 
which the data was obtained is listed in the appendix (Table A5, page 21). 
 
 

Step 1: Acquire and prepare the data. 
 

 1.1: Collect and prepare GTFS static data. 
 

Collect GTFS static data from all Canadian CMAs. This will take a few hours. See Table 2 for 
links to sources. Then open the GTFS files named “stops” in QGIS.  

 

Merge all the GTFS stops files into one file using Vector > Data Management Tools > Merge 
Vector Layers. Save merged file.  

 

 1.2: Create DA Buffers  
 

Use DA buffers that have already been created for Intersection Density Measure and are in 
PostGIS environment already. If you have not done this measure yet, see Section 2.2, Step 1. 
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1.3 Refining the calculation area to include only CMAs with transit data 
 

Download 2016 Canadian CMA (Census Metropolitan Area) Boundary file from Statistics Canada. 
Open in QGIS. Filter file to select only type B CMAs (classification for all CMAs not including 
CAs). Save filtered group as Canadian CMAs. Edit this file to remove any CMAs with no transit 
available data. Save as Transit CMAs. These are the areas where the transit measure will be 
calculated.  
 
Use Vector > Research Tools > Select by location for DA buffers when the buffer centroid falls 
within the area of Transit CMAs. Save. This is the DA buffer file that will be imported into postGIS 
along with the transit stops data.  

 

Step 2: PostGIS Processing 

 

 2.1: Load the data into PostGIS 
 

Open PgAdmin4 that has been installed with PostGIS extension.  
 

Import DA Buffers (if this has not already been done) and Transit Stops into PostGIS using 
Database > Database Manager > PostGIS. Check the create spatial index box and the convert 
field names to lowercase box. Make sure to specify the Geom SRID as 4269. 

 

 2.2: Prepare PostGIS Data  
 
  Create geography column for table(s) without one.  

 
2.3: Count the transit stops and stations in the buffers.  

 

 Count transit stops using the ST_Intersects function.  
 

Save the output using COPY. This is your Transit Stop count. Calculate z-scores for final 
measure. 
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3: Appendix 
 

Table A1: Summary Statistics of Derived ALE Measures 

 

 

  

Variable Source N 
Mean 
 value 

Standard 
deviation 

Minimum 
value 

Maximum 
value 

2006 Dataset 

ID 
Statistics Canada 
(2006 Road 
Network File) 

54,624 26.2 20.8 0 164.7 

DD 
Statistics Canada 
(Census 2006) 

54,214 868.2 1,129.6 0 11,506.4 

2016 Dataset 

ID 
OpenStreetMap 
road and footpath 
features 

56,589 48.8 54.6 0 1081.8 

DD 
Statistics Canada 
(2016 Census) 

56,089 941.7 1,256.6 0 14,747.6 

POI 
OpenStreetMap 
amenity features 

56,589 55.4 114.8 0 2,119 

TRANSIT Multiple sources 35,338 46.8 32.72 0 252 



17 
 

Table A2: Dissemination areas with null dwelling density  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(continues on next page)  

DAs with dwelling density values in 2006 (n=410) 

10010687 24140094 24870086 24830055 24990182 35540073 47170163 59331545 61060078 
10010693 24160035 24880047 24830056 24990183 35540142 47170188 59331547 61070025 
10010732 24210038 24880096 24840037 24990186 35560186 47170206 59331548 62040033 
10020080 24210040 24890074 24840056 24990187 35560189 47170208 59331572 62040035 
10020121 24220036 24890075 24850081 24990188 35560202 47170257 59331575 62040040 
10030056 24340074 24890143 24850082 24990189 35560278 47180156 59331576 62040043 
10030061 24340075 24890145 24850091 24990191 35560280 47180158 59331577 62040044 
10030065 24340163 24140094 24870086 24990194 35560337 47180159 59331578 62050013 
10050091 24340165 24160035 24880047 24990196 35570307 47180161 59331580 62080015 
10060074 24350026 24210038 24880096 24990200 35580363 47180173 59331581 62080020 
10070491 24350055 24210040 24890074 24990201 35580365 47180181 59331584 62080021 
10070500 24350056 24220036 24890075 24990204 35580366 47180211 59331585  
10070501 24350057 24340074 24890143 24990207 35580369 47180225 59331586  
10070564 24410067 24340075 24890145 24990233 35580371 48030115 59331589  
10080185 24620101 24340163 24890146 24990235 35580396 48030171 59331590  
10090078 24620102 24340165 24910096 35010176 35590070 48050162 59331601  
10090100 24620103 24350026 24910103 35010177 35590102 48050221 59331602  
10100061 24620104 24350055 24920051 35010379 35600206 48050222 59331603  
10100063 24620108 24350056 24930150 35010385 35600227 48061856 59331604  
10110001 24620109 24350057 24930151 35010386 35600241 48061900 59331605  
10110005 24620110 24410067 24930152 35010388 35600244 48061901 59331606  
12020086 24620189 24620101 24930154 35010389 35600254 48100200 59331607  
12030054 24620190 24620102 24940313 35010395 35600266 48111161 59331612  
12090845 24620191 24620103 24940333 35010396 35600295 48111989 59331613  
12120122 24620192 24620104 24940335 35010397 35600301 48112107 59331621  
12130034 24670285 24620108 24950049 35010398 35600304 48120241 59331624  
13060066 24690080 24620109 24960045 35061391 35600305 48120250 59331625  
13080107 24690081 24620110 24970068 35120375 35600307 48130200 59390128  
13090106 24690083 24620189 24970070 35120388 35600309 48130201 59390140  
13090170 24690085 24620190 24970074 35190001 35600311 48140055 59390198  
13090213 24690090 24620191 24970075 35190747 46010092 48160100 59410315  
13130065 24690091 24620192 24970082 35250863 46080061 48160102 59410363  
13130066 24690094 24670285 24970121 35280163 46150077 48160104 59430057  
13150209 24690096 24690080 24980041 35280165 46170096 48160109 59450030  
24010018 24780108 24690081 24980048 35290266 46180081 48160188 59470063  
24020036 24780137 24690083 24990137 35290267 46180089 48170227 59470098  
24020068 24790081 24690085 24990139 35360177 46180090 48170229 59490098  
24030039 24790082 24690090 24990140 35380197 46180092 48170240 59490101  
24030042 24790083 24690091 24990141 35380198 46200029 48170252 59490102  
24040057 24790084 24690094 24990143 35380199 46200049 48170264 59490103  
24050035 24790085 24690096 24990145 35390749 46210077 48170307 59490104  
24060058 24790086 24780108 24990149 35420227 46220088 48170326 59490106  
24060060 24790087 24780137 24990151 35430549 46220089 48170328 59490107  
24060068 24790088 24790081 24990156 35440255 46220090 48170349 59490108  
24070049 24790103 24790082 24990157 35440256 46220119 48170350 59490151  
24070050 24790136 24790083 24990158 35440258 46220120 48190313 59490179  
24070074 24790137 24790084 24990159 35480201 46220153 59010134 59550129  
24070083 24830051 24790085 24990160 35480228 47030110 59153616 59550231  
24070088 24830052 24790086 24990161 35490212 47050217 59190154 60010122  
24070089 24830053 24790087 24990162 35490214 47100164 59190305 60010123  
24070092 24830054 24790088 24990163 35510069 47100223 59190306 60010125  
24080080 24830055 24790103 24990164 35510078 47110581 59190308 60010127  
24090071 24830056 24790136 24990166 35510097 47150391 59210291 60010131  
24090072 24840037 24790137 24990167 35510101 47160253 59230148 60010132  
24100153 24840056 24830051 24990172 35510103 47160272 59270049 60010135  
24110023 24850081 24830052 24990177 35510104 47160285 59310127 60010191  
24140065 24850082 24830053 24990178 35520089 47160287 59331493 60010193  
24140093 24850091 24830054 24990180 35530347 47170152 59331519 61060075  
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DAs with dwelling density values in 2016 (n=500) 

10010693 24220036 24910103 24990253 35600265 48170328 59550121 60010124 62040032 

10010732 24340074 24920051 35010379 35600304 48170350 59550122 60010125 62040035 

10020080 24340075 24930151 35010385 35600305 59010216 59550123 60010126 62040038 

10020121 24340163 24930152 35010386 46010092 59070156 59550125 60010127 62040039 

10030056 24340165 24930154 35010388 46080061 59070301 59550126 60010128 62040040 

10030061 24350026 24940313 35010389 46180078 59090807 59550127 60010130 62040042 

10030065 24350055 24940333 35010395 46180079 59170642 59550128 60010131 62040044 

10070528 24350056 24940335 35010396 46180080 59170688 59550129 60010132 62040046 

10070564 24350057 24950037 35010397 46180081 59190154 59550130 60010135 62040048 

10080185 24620101 24950049 35010398 46180089 59190305 59550161 60010141 62040059 

10090078 24620102 24970068 35061391 46180090 59190308 59550162 60010191 62040060 

10090100 24620103 24970070 35120375 46180092 59210291 59550163 60010193 62040061 

10100061 24620104 24970074 35204479 46210077 59270049 59550164 60010236 62040062 

10100063 24620108 24970075 35280163 46220090 59270088 59550168 60010238 62040063 

10110001 24620109 24970082 35290267 46220119 59310127 59550169 60010239 62040064 

10110005 24620110 24970121 35290328 46220120 59331585 59550202 60010240 62040065 

12020086 24620189 24980041 35290329 46230062 59390128 59550211 60010241 62040066 

12030054 24620190 24980048 35290330 47010227 59390129 59550212 61010032 62040067 

12090845 24620191 24990137 35290331 47030110 59390190 59550213 61010033 62040068 

12120122 24620192 24990140 35290332 47060694 59390191 59550214 61010034 62040069 

12130034 24670285 24990141 35290333 47100164 59390192 59550215 61010035 62040070 

13060066 24690081 24990143 35360458 47100223 59390193 59550217 61010037 62040071 

13070343 24690083 24990145 35380357 47150391 59390194 59550218 61010045 62040072 

13080093 24690085 24990149 35390749 47160253 59410371 59550219 61010046 62050012 

13090106 24690091 24990151 35390753 47160272 59430057 59550220 61010047 62050013 

13090170 24780137 24990156 35390754 47160285 59470062 59550221 61010048 62050014 

13090213 24790081 24990157 35390756 47160287 59470098 59550222 61010049 62050017 

13100321 24790082 24990158 35390961 47160292 59490103 59550223 61010050 62080015 

13130065 24790083 24990159 35430549 47170163 59490104 59550224 61010051 62080020 

13130066 24790084 24990160 35440255 47170188 59490179 59550225 61010055 62080021 

13130140 24790085 24990161 35480201 47170206 59490206 59550226 61020139 62080022 

13140184 24790086 24990162 35490212 47170208 59510222 59550227 61030116 62080023 

13150209 24790087 24990163 35490214 47170257 59530200 59570209 61030140 62080024 

24010018 24790088 24990164 35510097 47180159 59530201 59570210 61040070 62080025 

24020036 24790103 24990166 35510101 47180173 59530202 59570217 61040072 62080026 

24020068 24790137 24990167 35510103 47180181 59530203 59570218 61040073 62080027 

24030039 24790160 24990172 35510104 47180211 59530204 59570219 61040081  

24030042 24790162 24990177 35520082 47180225 59530205 59590013 61040082  

24040057 24830051 24990178 35520089 47180252 59530206 59590014 61040084  

24050035 24830052 24990180 35530347 48030171 59530224 59590015 61040124  

24060058 24830053 24990182 35540073 48062444 59530227 59590016 61040127  

24060068 24830054 24990183 35560186 48080365 59530228 59590017 61040128  

24070049 24830095 24990186 35560189 48100200 59530229 59590018 61040136  

24070083 24830096 24990187 35560202 48111124 59530230 59590019 61040137  

24070088 24840037 24990188 35560278 48120241 59530231 59590020 61040139  

24070089 24840056 24990189 35560280 48120270 59530232 59590021 61050074  

24070092 24850081 24990191 35570313 48140055 59530233 59590022 61050075  

24090071 24850082 24990194 35570373 48150088 59530237 59590023 61050078  

24090072 24870043 24990196 35580366 48150089 59530238 59590024 61050080  

24100153 24870086 24990198 35580369 48150090 59530239 59590025 61050118  

24110023 24880047 24990200 35580371 48150127 59530240 59590026 61050126  

24120110 24880096 24990201 35580396 48160100 59530242 59590027 61050129  

24140065 24890074 24990204 35590102 48160102 59550115 60010118 61050130  

24140093 24890075 24990207 35590124 48160109 59550116 60010119 61050131  

24140094 24890145 24990233 35600221 48160188 59550117 60010120 61050142  

24160035 24890146 24990235 35600241 48170229 59550118 60010121 61060141  

24210038 24890170 24990248 35600244 48170252 59550119 60010122 61060163  

24210040 24910096 24990252 35600254 48170307 59550120 60010123 61060164  
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Table A3: Dataset and software download links 

 

 

  

Dataset or 
software 

Source Link 
File 
format 

Used to 
derive: 

Datasets used for the creation of measures   

Census 
housing data 

Statistics 
Canada 

http://dc1.chass.utoronto.ca/census/  

Comma 
separated 
values 
(.csv) 

Dwelling 
density  

Census 
Metropolitan 
Areas 

Statistics 
Canada 

http://www12.statcan.gc.ca/census-
recensement/2011/geo/bound-limit/bound 
-limit-2016-eng.cfm  

Shapefile 
(.shp) 

CMAs used 
for transit 
measure 

Dissemination 
area (DA) 
boundary files 

Statistics 
Canada 

2006: http://www12.statcan.gc.ca/census-
recensement/2011/geo/bound-limit/bound 
-limit-2006-eng.cfm  
2016: http://www12.statcan.gc.ca/census-
recensement/2011/geo/bound-limit/bound-
limit 
-2016-eng.cfm 

Shapefile 
(.shp) 

DA circular 
buffers  

OSM Provincial 
Extracts 

OpenStreetMap 
http://download.geofabrik.de/north-
america/canada.html  

Shapefile 
(.shp) 

Intersection 
density 
(2016), POI 
measure 

Road Network 
File  

Statistics 
Canada 

http://www12.statcan.gc.ca/census-
recensement/2011/geo/rnf-frr/index-eng.cfm 

Shapefile 
(.shp) 

Intersection 
density 
(2006) 

Transit Stops  
Municipal or 
transit agency 
websites  

https://transitfeeds.com/l/32-canada 

Comma 
separated 
values 
(.csv) 

Transit 
measure 

Software download links 

QGIS  QGIS 
http://www.qgis.org/en/site/forusers/ 
download.html  

- 
Several 
measures 

PostgreSQL & 

PostGIS 
PostgreSQL  https://www.PostgreSQL.org/download/  - 

Several 
measures 

Other useful datasets 

PCCF+ 
Statistics 
Canada 

http://www5.statcan.gc.ca/olc-
cel/olc.action?ObjId=82F0086X&ObjType=2 
&lang=en&limit=0  

SAS 
control 
program 
and 
datasets  

For linkage 
to Postal 
Codes 
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Table A4: Mean Values of Each ALE Measure for by Class Group 

 

  

Group 
Intersection 

density 
Dwelling 
density 

Points of 
interest 

Transit stops ALE-Index 

2006 ALE Class 

1 (very low) 5.6 61.7 - - -1.7 

2 (low) 29.5 581.5 - - -0.1 

3 (moderate) 40.0 1,114.1 - - 0.9 

4 (high) 47.9 2,060.5 - - 2.1 

5 (very high) 60.4 4,352.4 - - 4.7 

2016 ALE Class 

1 (very low) 7.4 71.1 5.2 - -1.9 

2 (low) 49.0 661.4 38.4 - -0.4 

3 (moderate) 75.1 1,272.3 67.0 - 0.8 

4 (high) 100.1 2,548.5 125.8 - 2.8 

5 (very high) 173.5 5,366.5 408.1 - 8.9 

2016 ALE/Transit Class 

1 (very low) 15.2 170.6 11.6 8.2 -1.6 

2 (low) 57.0 789.1 46.3 37.9 -0.1 

3 (moderate) 78.9 1,399.2 73.3 57.5 1.1 

4 (high) 103.9 2,718.6 135.1 77.2 3.1 

5 (very high) 178.4 5,534.1 429.1 103.4 9.3 
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Table A5: Sources and download dates for transit measure stops data 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Asterisk (*) indicates that data source was located via the TransitFeeds portal. All other data was obtained from the official 
websites of the listed agencies 

Census Metropolitan 
Area (CMA) 

Download source Download date 

Abbotsford - Mission BC Transit* November 1, 2017  

Barrie  Barrie Transit*  November 1, 2017  

Belleville  No Data Available N/A 

Brantford  Brantford Open Data Portal December 19, 2017 

Calgary Calgary Transit* November 1, 2017  

Edmonton 
Edmonton Transit System*, Strathcona 
County Transit*, St Albert Transit* 

November 1, 2017  

Greater Sudbury Greater Sudbury Transit* November 1, 2017  

Guelph Guelph Transit* November 1, 2017  

Halifax MetroTransit* November 1, 2017  

Hamilton  Hamilton Street Railway, BurlingtonTransit* November 1, 2017  

Kelowna  BC Transit* November 1, 2017  

Kingston  City of Kingston* November 1, 2017  

Kitchener–Cambridge–
Waterloo 

Grand River Transit* November 1, 2017  

Lethbridge Lethbridge Open Data Portal December 11, 2017 

London London Transit Commision* November 1, 2017  

Moncton  Codiac Transpo* November 1, 2017  

Montreal  AMT*, STM*, STL* November 1, 2017  

Oshawa  Durham Region Transit* November 1, 2017  

Ottawa–Gatineau OC Transpo*, STO* November 1, 2017  

Peterborough  No Data Available N/A 

Quebec City  RTC*, STLévis Données Ouverts November 1, 2017  

Regina The City of Regina* November 1, 2017  

Saguenay No Data Available N/A 

Saint John  
The City of Saint John Open Data 
Catalogue 

November 21, 2017 

Saskatoon City of Saskatoon* November 1, 2017 

Sherbrooke  STS* November 1, 2017 

St. Catharines–Niagara  Regional Municipality of Niagara* November 1, 2017 

St. John's  MetroBus Transit* November 1, 2017 

Thunder Bay Thunder Bay Transit* November 1, 2017 

Toronto  
TTC*, GoTransit*, MiWay*, Brampton 
Transit*, York Region*, Oakville Transit* 

November 1, 2017 

Trois-Rivières No Data Available N/A 

Vancouver  TransLink* November 1, 2017 

Victoria  BC Transit* November 1, 2017 

Windsor  City of Windsor* November 1, 2017 

Winnipeg Winnipeg Transit* November 1, 2017 
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Figure A1: Reference Maps of Four Canadian Urban Areas by their 2016 ALE Class Value 
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